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1 Allgemeines
PABS steht für [P]rogrammier[a]bgaben [B]ewertungs[s]ystem und wird an der Universität Würz-
burg entwickelt. PABS unterstützt Studenten beim Erlernen der Grundtechniken des Programmie-
rens und im Programmieralltag notwendiger Tools, wie IDE und Versionskontrollsystem.

2 Voraussetzungen
Zur Nutzung von PABS sind einige Voraussetzungen zu erfüllen. PABS ist nur aus dem Netzwerk
der Universität Würzburg erreichbar. Zur Nutzung muss ein Arbeitsplatzrechner in der Uni, das
WLAN auf dem Campus oder eine VPN-Verbindung (Abschnitt 2.1) genutzt werden. Weiterhin
sind die notwendigen Entwicklertools, eine aktuelle Version von Java (Abschnitt 2.2) und eine
Entwicklungsumgebung (Abschnitt 2.3) zu installieren. Weiterhin ist ein Client für den Zugriff auf
ein Subversion Repository (Abschnitt 2.4) notwendig.

2.1 VPN
PABS ist nur im Netzwerk der Universität erreichbar. Um auch von zuhause oder unterwegs auf
PABS zugreifen zu können, ist es daher notwendig, eine Verbindung zur Universität aufzubauen.
Auf den Seiten des Rechenzentrums gibt es Anleitungen zum Einrichten einer VPN-Verbindung.
Bei Problemen stellt das Rechenzentrum eine Hotline zur Verfügung.

2.2 Java
Für die Ausführung der Entwicklungsumgebung und die Bearbeitung der Aufgaben ist es notwen-
dig, eine aktuelle Version des Java Development Kit (JDK) zu installieren.

2.3 Integrierte Entwicklungsumgebung
Zur Bearbeitung der Aufgaben kann eine beliebige Integrierte Entwicklungsumgebung (IDE) ge-
nutzt werden. Für das Programmierpraktikum wird Intellij (Abschnitt 2.3.1) empfohlen.
Dieses wird auch in der Abschlussaufgabe verwendet!

2.3.1 Intellij

Intellij IDEA ist (in der Community Edition) eine frei verfügbare Entwicklungsumgebung mit einer
großen Entwicklergemeinde und vielen Plugins. Im Programmierpraktikum wird der Einsatz von
Intellij empfohlen, ist aber nicht zwingend notwendig.
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Je nach Betriebssystem kann das Programm ganz normal installiert werden (Windows, macOS)
oder als portable Version in einem Archiv heruntergeladen werden.

2.3.2 Andere

Grundsätzlich kann eine beliebige Entwicklungsumgebung verwendet werden. Zu den bekanntesten
Entwicklungsumgebungen und Editoren zählen:

• Eclipse

• Netbeans

• Emacs

2.4 Subversion
Der Quellcode der einzelnen Aufgaben wird in einem Subversion Repository verwaltet. Für jeden
Kurs existiert ein Repository in dem jeder Student einen Unterordner bekommt, auf den nur er
zugreifen kann. Der Zugriff auf das Repository erfolgt mit Hilfe eines Clients. Es existiert eine
Vielzahl von Clients und die meisten Entwicklungsumgebungen haben entweder einen Subversion
Client integriert oder er kann als Plugin installiert werden.
Eine Einführung in Subversion würde den Rahmen der Anleitung sprengen, daher wird hier darauf
verzichtet und auf Google verwiesen.
In dieser Anleitung wird die empfohlene Entwicklungsumgebung Intellij und das stan-
dardmäßig vorhandene Subversion-Plugin verwendet.

2.5 Subversion Installation (Linux)
2.5.1 Linux

Die am häufigsten installierten Linux Distributionen verwenden entweder den Paketmanager apt
(Ubuntu, Debian, Linux Mint) oder dnf (Fedora, OpenSuse, RedHat). Mit dem folgenden Kom-
mando können Sie jeweils subversion installieren:

Fedora, OpenSuse, Redhat

1 sudo dnf install subversion

Ubuntu, Debian, Linux Mint

1 sudo apt install subversion

2.5.2 Subversion Installation (Windows)

Für Windows gibt es verschiedene Distributoren, die Installationsarchive für Subversion zur Ver-
fügung stellen. Wir empfehlen die Verwendung von SlikSVN. Achten Sie darauf die 64-Bit Version
herunterzuladen. SlikSVN kommt als ZIP-Archiv in dem sich eine Installationsdatei befindet. Der
Installer leitet Sie durch den Installationsvorgang.
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2.5.3 Subversion Installation (Mac)

Ältere Versionen von MacOS kommen mit einer nun veralteten SVN Version. Sie müssen daher
eine aktuelle Version nachinstallieren.

Homebrew installieren Homebrew ist ein Paketmanager mit dem man einfach Pakete nachin-
stallieren kann. Installieren Sie zunächst Homebrew, in dem Sie ein Terminal öffnen und die auf
der Homepage angegebene Zeile kopieren und ausführen.

Subversion über Homebrew installieren Geben Sie anschließend im Terminal folgende Zeile
ein und bestätigen Sie mit Enter. Homebrew installiert dann die aktuellste Subversion Version für
Sie:

1 brew install svn

2.5.4 IntelliJ IDEA Subversion Plugin einrichten

Das Subversion Plugin von IntelliJ IDEA muss noch konfiguriert werden, damit es den installierten
Subversion Client korrekt verwenden kann. Je nach Betriebssystem müssen hier unterschiedliche
Installationspfade angegeben werden.
Wählen Sie hierzu unter Linux/Windows Datei → Einstellungen (File → Settings) bzw. für Mac
Intellij Menü → Preferences aus und Suchen Sie im folgenden Dialog die Kategorie Version Control
und darin die Unterkategorie Subversion. Setzen Sie nun das Häkchen bei Use command line client:
und tragen Sie je nach Betriebssystem einen der folgenden Pfade ein (siehe Abbildung 1):

Linux

1 /usr/bin/svn

MacOS

1 /usr/local/bin/svn

Windows

1 C:\Program Files\SlikSvn\bin\svn.exe

3 PABS

3.1 Registrierung und Login
Um PABS nutzen zu können, müssen Sie sich bei PABS anmelden, die Registrierung erfolgt auto-
matisch (vgl. Abbildung 2).
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Abbildung 1: Dialog zur Konfiguration des SVN Clients.

Zur Anmeldung benötigen Sie den Login und das Passwort des Novell-Accounts (s123456 ), den
Sie vom Rechenzentrum erhalten haben. Das Passwort wird von PABS nicht gespeichert. PABS
nutzt den zentralen Verzeichnisdienst um Ihre Anmeldedaten zu überprüfen.

Abbildung 2: Das Formular zum Anmelden.

3.2 In Kurse einschreiben

Abbildung 3: Das Kursmenü.

PABS wird von mehreren Veranstaltungen
gleichzeitig verwendet, daher müssen Sie sich
zunächst in den entsprechenden Kurs einschrei-
ben, bevor Sie mit der Bearbeitung der Aufga-
ben beginnen können. Klicken Sie dazu links
oben auf das Courses-Menü (Abbildung 3).
Das Menü besteht aus zwei Abschnitten. Im
oberen Abschnitt finden Sie Links zu allen Kur-
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sen, in die Sie sich bereits eingeschrieben ha-
ben. Die Kurse sind in einem Baum nach Jahr
und Semester sortiert. Im unteren Abschnitt
finden Sie einen Link zu einer Übersichtsseite
aller Kurse. Auf dieser Seite können Sie sich in
neue Kurse einschreiben.
Die Kurse auf der Übersichtsseite sind wie im
Menü in einer Baumstruktur nach Jahr und
Semester sortiert dargestellt. Für Kurse in die
Sie bereits eingeschrieben sind, finden Sie einen
Link zum Kurs. Für Kurse in die Sie noch nicht
eingeschrieben sind finden Sie einen Link zur Einschreibung. Klicken Sie auf Subscribe um sich in
einen Kurs einzuschreiben (Abbildung 4). Bei einigen Kursen ist ein Passwort für die Einschreibung
notwendig. Erfragen Sie das Passwort gegebenenfalls beim Betreuer des Kurses.

Abbildung 4: Die Übersicht über alle Kurse.

3.3 Die Kursübersicht
Auf der Startseite des Kurses sieht man eine Liste mit Informationen zu den einzelnen Aufgaben
(Abbildung 5). Die Aufgaben sind nach der verbleibenden Bearbeitungszeit sortiert. Den Namen
der Aufgabe finden Sie in der linken oberen Ecke, die verbleibende Bearbeitungszeit steht rechts
oben. Zusätzlich finden Sie Angaben zu Beginn und Ende der Bearbeitungszeit und der Anzahl
der Revisionen, die Sie bereits hochgeladen haben. Außerdem wird der Bearbeitungsstatus der
Aufgabe angezeigt und die Aufgabe entsprechend farblich hinterlegt:

Failing (rot)
Die Aufgabe ist noch nicht erfolgreich bearbeitet worden. Einige Tests werden noch nicht
bestanden.

Success (grün)
Die Aufgabe wurde erfolgreich bearbeitet, es wurde aber noch keine Lösung eingereicht.
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Solution (blau)
Die Aufgabe wurde erfolgreich bearbeitet und eine der korrekten Revisionen wurde als Lösung
markiert.

Achten Sie darauf, vor dem Ende des Bearbeitungszeitraums mindestens eine Revision
als Lösung zu markieren!
Weiterhin finden Sie Links zur Aufgabenstellung (Instructions) sowie zur Liste der von Ihnen
erzeugten Versionen (Revisions) und einen Link zum Subversion Repository für diese Aufgabe.

Abbildung 5: Übersicht zu einer Aufgabe.

3.4 Die Liste der erzeugten Versionen
Wenn Sie dem Link zu den erzeugten Versionen (Revisions) folgen, zeigt PABS Ihnen eine Tabelle
mit allen von Ihnen erzeugten Revisionen. (Eine Revision wird erzeugt, wenn Sie das Kommando
svn commit ausführen. Folgende Informationen zu den Revisionen werden angezeigt:

Revision
Die eindeutige Nummer der Revision.

Author
Der Benutzer, der diese Revision erzeugt hat.

Timestamp
Der genaue Zeitpunkt, zu dem die Revision erzeugt wurde.

State
Der Status, in dem sich die Revision befindet.

Message
Die beim Commit erzeugte Nachricht.

Actions
Menüs für auf der Revision auszuführende Aktionen (Testen, Details anzeigen, als Lösung
einreichen).

Eine von Ihnen durch einen Commit erzeugte Version durchläuft mehrere Stadien. Zunächst ist Sie
NotEvaluated. Wenn Sie PABS angewiesen haben, diesen Commit auf Fehler zu testen, ändert sich
der Status auf EvaluationPending. Sobald die Tests durchgeführt wurden, ändert sich der Status
auf Success oder Failing. Je nachdem ob alle Test bestanden wurden oder nicht. PABS bietet Ihnen
für getestete Versionen mit dem Status Success an, diese als Lösung einzureichen, dies geht unter
Actions mit dem Eintrag Submit as Solution. Es ist weiterhin möglich, eine detaillierte Auflistung
der Fehler abzurufen. Wählen Sie dazu unter Actions den Eintrag Show details aus.
Denken Sie daran, eine erfolgreich getestete Abgabe rechtzeitig als Lösung einzurei-
chen, da Sie sonst keine Punkte bekommen können!
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4 Aufgabe bearbeiten
Um die Aufgaben bearbeiten zu können, müssen Sie sich zunächst eine lokale Kopie (Working Copy)
des entsprechenden Ordners im Subversion Repository erzeugen und anschließend die Aufgabe
korrekt anlegen. PABS kann dann Versionen, die hochgeladen wurden, testen.
Sollten Sie nicht Intellij verwenden, ist es wichtig zu beachten, dass alle Quelldateien im Projekt-
unterverzeichnis mit dem Namen src angelegt werden!

4.1 Intellij
Es wird hier davon ausgegangen, dass Sie Intellij und eine passende SVN-Schnittstelle nutzen.

4.2 Projekt importieren
Zum Import von Projekten aus Pabs, starten Sie zunächst Intellij. Wählen Sie dann File → New
→ Project from Version Control → Subversion (vgl. Abbildung 6).

Abbildung 6: Klickpfad zur Erzeugung eines neuen SVN Projekts.

Es öffnet sich ein neues Fenster in dem alle bereits bekannten SVN Repositories angezeigt werden.
Zur Bearbeitung einer neuen Aufgabe klicken Sie auf das grüne Plus: Abbildung 7.
Wiederum öffnet sich ein neues Fenster. Tragen Sie dort in das Textfeld die URL der zu bearbei-
tenden Aufgabe ein: Abbildung 9 (Dieser Link befindet sich in PABS im Revisionsmenü (bzw. in
der Übersicht) der Aufgabe und kann übber Rechtsklick auf ”Repository Link” via ”Link-Adresse
kopieren” (o. Ä.) in die Zwischenablage kopiert werden).
Bestätigen Sie mit einem Klick auf OK. Sie kommen zurück auf das Fenster mit dem grünen Plus.
Markieren Sie nun das gewünschte Repository mit einem Klick und bestätigen anschließend mit
Checkout (vgl. Abbildung 8).
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Abbildung 7: Übersicht aller SVN Reposito-
ries.

Abbildung 8: Hinzugefügte Repositories.

Abbildung 9: Beispiel eines neuen Repositories.

Anschließend gelangen Sie zu einem neuen Fenster in dem Sie einen Pfad zur Speicherung wählen
und die Struktur Ihres Projektes auswählen: Abbildung 10. Bestätigen Sie wiederum mit ”OK”.

4.3 Version hochladen
4.3.1 JAVA Projekt einrichten

Je nach Projekteinstellung können nun zwei Fälle eintreten:

1. Das Modul enthält einen src-Ordner:
Lesen Sie weiter bei Abschnitt 4.3.2.

2. Es existiert kein solcher Ordner:
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Abbildung 10: Übersicht der Ordnerauswahl.

Setzen Sie einen Rechtsklick auf das Modul und wählen Create New Folder und nennen
Sie diesen src. Wählen Sie anschließend mit einem Rechtsklick auf den src-Ordner, Mark
as Sources Root. Im letzten Schritt müssen Sie noch das JDK einbinden: File → Project
Structure. Bei Project SDK wählen Sie das installierte JDK aus dem Dropdown-Menü. Als
Project Language Level wählen Sie am besten 8, so werden Ihnen die aktuellsten Tipps zur
Sprache gegeben. Empfohlen wird jedoch mindestens Level 7 (multi-catch, usw.)
Des Weiteren kann es vorkommen, dass der Compiler output path nicht gesetzt wird. Ist dies
der Fall, muss unter File → Project Structure → Project → Project compiler output „out”
manuell als Ordner eingetragen werden.

4.3.2 Ressourcen dem Projekt hinzufügen

Wann immer Sie eine neue Datei oder auch Ordner erzeugen, müssen Sie diese (diesen) der Ver-
sionskontrolle hinzufügen. Wählen Sie mit einem Rechtsklick das entsprechende Objekt aus und
wählen Subversion → Add to VCS.
Beachten Sie, dass PABS ausschließlich den src-Ordner verlangt und alle Pakete innerhalb dieses
erzeugt werden müssen.

4.3.3 Projekte commiten

Sollten Sie Ihr Programm zum Testen abgegeben wollen, so wählen Sie den src-Ordner mit Rechtsklick
an und navigieren dann zu Subversion → Commit Directory.
Es öffnet sich ein neues Fenster mit einer Übersicht aller neuen bzw. geänderten Dateien. Wählen
Sie dort Commit.

5 Troubleshooting

5.1 svn: E175002: handshake alert: unrecognized_name
Wenn Sie diesen Fehler erhalten, öffnen Sie die Datei eclipse.ini, die im Hauptordner ihrer Eclipse-
Installation liegt. Fügen Sie dort an beliebiger Stelle die folgende Zeile ein und starten Sie Eclipse
neu:
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-Djsse.enableSNIExtension=false

5.2 Verbindung zu PABS nicht möglich
Überprüfen Sie die VPN-Verbindung. Überprüfen Sie mit einem IP Lookup Dienst, ob Sie kor-
rekt verbunden sind. Als Eigentümer der IP-Adresse sollte der Dienst die Universität Würzburg
anzeigen.
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